Подсчет повторяющихся значений

Понадобилось определить количество одинаковых строк в списке. Можно было бы это сделать и вручную, но в списке около 300 000 значений. На поиск решения потратил где-то полчаса, в итоге всё оказалось довольно просто.

Первый способ с Экселем. Если все значения в столбце А, то вставляем формулу =СЧЁТЕСЛИ($A$1:$A$11;A1) в столбец B и растягиваем.

Подсчёт числа дублей в Excel

Второй способ подходит тем, у кого установлен дистрибутив Linux, BSD или macOS. Запускаем терминал и вводим sort файл.txt | uniq -c | sort -nr

Сортировка значений в терминале

uniq отображает только уникальные значения из файла, ключ -c добавляет перед значением количество повторений.
sort -n отсортировывает значения по возрастанию, -r изменяет направления сортировки и она становится по убыванию.

Пост опубликован: 06.01.2017

Теги: